模拟栈

实现一个栈,栈初始为空,支持四种操作:

  1. push x – 向栈顶插入一个数 x𝑥;
  2. pop – 从栈顶弹出一个数;
  3. empty – 判断栈是否为空;
  4. query – 查询栈顶元素。

现在要对栈进行 𝑀 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。

输入格式

第一行包含整数 𝑀,表示操作次数。

接下来 𝑀 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 emptyquery 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YESNOquery 操作的查询结果为一个整数,表示栈顶元素的值。

数据范围

1≤M≤100000,
1≤x≤10^9
所有操作保证合法。

输入样例:

1
2
3
4
5
6
7
8
9
10
11
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty

输出样例:

1
2
3
4
5
5
5
YES
4
NO

用数组模拟栈

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#include<iostream>
using namespace std;
const int N = 1e5;
int stack[N];
int top=-1;

void push(int x){
stack[++top]=x;
}

void pop(){
top--;
}

int isempty(){
return top==-1 ? 1:0;
}

void query(){
cout<<stack[top]<<endl;
}

int main(){
int m;
cin>>m;
while(m--){
string a;
cin>>a;
if(a=="push"){
int x;
cin>>x;
push(x);
}
if(a=="pop"){
pop();
}
if(a=="empty"){
int ans=isempty();
if(ans) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
if(a=="query"){
query();
}
}
return 0;
}